UBTV and App market not working.

I have the Gen 2 Unblock Tech box. I haven't used it in months and just turned it on. UBTV doesn't' work and the app market doesn't load anything. I found this site by googling to see what is wrong with the box.

Was there an update for the box that I need to load?



  • edited June 2019
    Hi, my UBTV app is also not working. Every time I load it up, it brings up an "upgrade" (or update) window and says I have to be patient and let it do the update. I let it "upgrade" overnight and it's still the same no progress on the upgrade bar at all. What should I do to resolve this issue?
  • Same here. We haven’t powered ours on in over a year (perhaps two).

    My wife just tried every menu she could find, and was able to update something called “UBLive”, which then seemingly made some version of Ubtv work, with a blue loading screen.

    Trouble is, this was within a menu within a menu, and we don’t know how to get back to it...

    The default (secondary) menu still have the same errors and refusals to download.
  • edited June 2019

    This is the app that works (trouble is that you need a few clicks to reach it).

    This is how it looks (UBTV is the large icon on the left), and I’d love to know how to set this as the standard app (even though I don’t know how to reach the Android settings through this particular app, I would still like it to appear when I press the Home button).
  • bamby8bamby8 Junior Member
    edited June 2019
    Have you tried adding the app to the 'My Favourites' menu accessible from the main ubox launcher screen (green coloured tile I think), by pressing the huge + icon to select the app?

    Only downside of this method is every time the winlauncher is updated, all the app icons are deleted from the 'My Favourites' menu in our experience.
  • alexlihawaiialexlihawaii Just Watchin`
    They are upgrading .
    only live TV is working right now.
    If you need the apps, you can go to http://www.ub1234.com to download all the apps and install.
    all you needs is waiting until they finishing the upgrade.
  • In most cases you need to completed uninstall the app and reinstall from appmarket.

    But what I found is this does not work with Replay App. It is also not available from that site above.

    Replay App simple shows upgrading but no progress at all
Sign In or Register to comment.