EVPad 3 wifi ethernet issues

Just purchased EVPad 3, even though the WiFi is connected and ethernet is connected, the home page still says I am not connected, no / empty "IP:" on home screen, when I click HDTV or VOD, I always gets "No application for the time being, please connect to the Internet to download". I've tried turning WiFi on/off and only using ethernet, but none of these combinations work. Any help much appreciated! Thanks!


  • SomebodySomebody Junior Member
    Sounds like a faulty box. Return and exchange for a new one.
  • wsthongwsthong Just Watchin`
    Not sure it will help. Have you tried installing using the 6868 code for initial set up
    Thanked by 1padman
  • Thanks for all suggestions, tried 6868, it displayed error on all downloads but when I came back out, the internet suddenly came on! :p :o =) Thanks wsthong!
  • Hello! I currently have the same problem after doing factory reset on the evpad box and this is the only thread that I’ve found that discusses this issue. Can anyone help me how do you make the initial set-up appear so i could input the code 6868? Whenever i try to reset it, nothing lets me input a code for set-up

Sign In or Register to comment.